新闻资讯

nat路由器技术详解,带您了解网络技术

2019-04-10

NAT (Network Address Translation) 中文含义为网络地址转换。简单的讲NAT技术就是将内部私有地址转化为可以在外部网络使用的公网。NAT技术不仅完美地解决了lP地址不足的问题,还能有效地避免来自网络外部的攻击,隐藏并保护网络内部的。

NAT实现方式:静态转换、动态转换、端口多路复用

静态转换
静态转换是指将内部网络的私有IP地址转换为公有IP地址,IP地址为一对一。借助静态转换,可以实现外部网络对内部网络中某些特定设备的访问(比如某个特定服务器)。
动态转换
动态转换是指将内部网络的私有IP地址转换为公用IP地址时,内网、外网IP地址都是随机的。可实现某些内网地址段与几个合法公网IP地址之间的地址转换。
端口多路复用
端口多路复用(Port address Translation,PAT)是指改变外出数据包的源端口并进行端口转换。可实现内部网络的所有主机通过一个合法公网IP地址访问外部网络,从而可以最大限度地节约IP地址资源。同时,又可隐藏网络内部的所有主机,有效避免来自外部网络的攻击。
下面以端口多路复用技术为例讲解 NAT的配置方法。
拓扑图
零基础学习网络技术——路由器NAT技术

基础网络部分配置
Router0配置方法
Router>
Router>enable(进入特权模式)
Router#config(进入全局配置模式)
Router(config)#hostname r1(改名)
r1(config)#int s0/0/0(进入s0/0/0接口配置模式)
r1(config-if)#encapsulation ppp(封装ppp协议)
r1(config-if)#ip add 202.99.192.100 255.255.255.0(配置ip地址)
r1(config-if)#clock rate 64000(配置时钟频率)
r1(config-if)#no shutdown(启用端口)
r1(config-if)#int f0/0
r1(config-if)#no shutdown
r1(config-if)#ip add 192.168.10.1 255.255.255.0
r1(config-if)#
Router1配置方法
Router>
Router>ena
Router#conf
Router(config)#hostname r2
r2(config)#int s0/0/0
r2(config-if)#no shut
r2(config-if)#encapsulation ppp
r2(config-if)#ip add 202.99.192.101 255.255.255.0
r2(config-if)#int f0/0
r2(config-if)#no shut
r2(config-if)#ip add 10.10.10.1 255.255.255.0
r2(config-if)#
交换机作为联通设备无需配置。
按照拓扑图分别为计算机配置ip地址。其他计算机配置IP地址与之类似
零基础学习网络技术——路由器NAT技术

做网络测试
零基础学习网络技术——路由器NAT技术

接下来做NAT配置
在route 0配置nat
r1(config)#
r1(config)#ip access-list standard 1(创建内部地址列表)
r1(config-std-nacl)#permit 192.168.10.0 0.0.0.255
(允许192.168.10.0这个网段,子网掩码为反掩码)
r1(config-std-nacl)#exit
r1(config)#ip nat inside source list 1 interface s0/0/0 overload
(配置nat转换,把list 1 的内部地址通过s0/0/0接口转发出去,外部网络只能看到s0/0/0接口地址)
r1(config)#int f0/0
r1(config-if)#ip nat inside(设置nat入接口)
r1(config-if)#int s0/0/0
r1(config-if)#ip nat outside
r1(config-if)#exit
r1(config)#ip route 0.0.0.0 0.0.0.0 202.99.192.101(设置nat出接口)
r1(config)#
做测试

花生壳是贝锐旗下知名的动态域名解析服务,能将动态IP地址实时与服务器保持交流,绑定固定域名,让用户输入特定域名即可访问某台内网主机,并支持内网穿透,摆脱无公网IP及NAT转发导致无法使用的问题,为中国一代代互联网人解决了众多基础的网络连接问题。

最新资讯
相关资讯
热门专题
最新专题